Mails not sending
Incident Report for raidboxes®
Resolved
This incident has been resolved.
Posted Jun 22, 2019 - 19:52 CEST
Update
We have fixed the issue and mails are delivered again, All missing mails will be resend now.
Posted Jun 22, 2019 - 19:51 CEST
Investigating
We are currently investigating the issue.
Posted Jun 22, 2019 - 11:45 CEST
This incident affected: Emails (Box Emails).