Mails not sending
Incident Report for raidboxes®
Resolved
The functionality has been completely restored and all mails will be sent.
Posted May 28, 2019 - 14:47 CEST
Update
We are continuing to investigate this issue.
Posted May 28, 2019 - 11:40 CEST
Investigating
Mails currently not sending.
Posted May 28, 2019 - 03:00 CEST
This incident affected: Emails (Box Emails).