Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2025 - 22:00 CEST
Scheduled
We’ll be performing scheduled maintenance on the Raidboxes Dashboard and related services. During this period, some Dashboard actions may be temporarily unavailable or may not work as expected due to brief downtimes for individual services.
Your Boxes, domains, and email servers will remain online and accessible throughout the maintenance window.
Posted Aug 08, 2025 - 15:45 CEST
This scheduled maintenance affected: Operational Systems (Dashboard, Dashboard 2FA Service, Contract Management and Billing System).