Scheduled maintenance of Raidboxes webmailer

Scheduled for Feb 5, 08:30 - 08:35 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 03, 2026 - 07:28 CET

Scheduled

We'll be undergoing scheduled maintenance during this time for important security updates. This maintenance only affects our new mail infrastructure.

Expected downtime: Approximately 1 minute
Posted Feb 03, 2026 - 07:28 CET
This scheduled maintenance affects: Emails (Raidboxes Webmailer).