Partial system outage at mailbox.org
Incident Report for raidboxes®
Resolved
Mailbox.org just reported their systems as operational. We therefore resolve this issue as well. Should you experience any problems with managing your inboxes, please feel free to contact us at any time :)
Posted Mar 31, 2021 - 15:48 CEST
Update
Update: According to mailbox.org email service are not affected by the outage. This means that you should be able to send and receive emails as usual.

However, the setup process for new email inboxes as well configuration steps for existing inboxes (adding new aliases, redirects and blacklist items for example) are impeded at the moment.
Posted Mar 31, 2021 - 15:30 CEST
Investigating
Mailbox.org is experiencing partial outages of their service at the moment. This directly affects your email inboxes with RAIDBOXES. We don't have any specifics on the incident yet. We will update this incident report as soon as we do.

For a better overview we recommend that you also check mailbox.org's status page: https://status.mailbox.org/
Posted Mar 31, 2021 - 14:47 CEST
This incident affected: Emails (Box Emails).